Tls 1.3 지원 추가 건의

이번에 시놀로지 DSM이 7.0으로 업데이트되면서 TLS 1.3을 지원하게 되었습니다.

설정에서 TLS 보안 프로파일 수준을 '최신 호환성’으로 설정하면 TLS 1.3만을 지원하도록 바꿀 수 있습니다. (기본값으로는 TLS1.3/1.2 두 버전을 지원)

근데 이렇게 TLS 1.3만을 지원하는 상태에서는 RaiDrive를 사용해 시놀로지 WebDAV에 접속할 수 없습니다.

“원인: 요청이 중단되었습니다. SSL/TLS 보안 채널을 만들 수 없습니다” 라는 메시지가 뜨는 걸로 봐선 RaiDrive가 TLS1.3을 지원하지 않는 것 같습니다.

TLS 1.3을 지원하도록 기능 추가가 되면 좋을 것 같습니다.

안녕하세요, @hansoli 님.

RaiDrive 최신 버전(2021.5.20)은 TLS 1.3을 지원하도록 설정되어 있습니다.
다만 Synology 설정에서 최신 호환성으로 할 경우 .Net이 제대로 동작하지 않습니다.
따라서 중간 호환성으로 해야 TLS 1.3연결이 제대로 됩니다.
이 문제는 마이크로소프트의 .Net의 문제이며, 이에 대한 연구를 하고 있습니다.

좋아요 1